1. Trang chủ >
  2. Công Nghệ Thông Tin >
  3. Chứng chỉ quốc tế >

Now examine the following show flash command, which was issued immediately after the show ip r...

Bạn đang xem bản rút gọn của tài liệu. Xem và tải ngay bản đầy đủ của tài liệu tại đây (4.93 MB, 638 trang )


03.35700737 CH02 Page 68 Wednesday, February 17, 1999 2:42 PM



68



Chapter 2: Understanding Cisco’s Internetwork Operating System (IOS) Software



Example 2-11 show running-config on Router Nova

hostname Nova

banner # This is the router in Nova Sibiersk; Dress warmly before entering! #

!

boot system flash c2500-j-l.112-14.bin

boot system rom

!

enable password cisco

!

interface Serial0

ip address 134.141.12.2 255.255.255.0

!

interface Serial1

ip address 134.141.23.2 255.255.255.0

!

interface Ethernet0

ip address 134.141.2.2 255.255.255.0

!

router rip

network 134.141.0.0

!

line con 0

password cisco

login

line aux 0

line vty 0 4

password cisco

login

!

config-register 0x2101



03.35700737 CH02 Page 69 Wednesday, February 17, 1999 2:42 PM



Scenario 2-1 Answers



69



Answers to Scenarios

Scenario 2-1 Answers

In Scenario 2-1, the following commands were added to the configuration:













enable-secret as a global command

prompt as a global command

no cdp enable as an Ethernet0 subcommand

The hostname command also was changed



The scenario question’s answers are as follows:

1. If the hostname was changed to SouthSiberia first and then the prompt command added



during the intervening time, the prompt would have been SouthSiberia. Configuration

commands are added to the RAM configuration file immediately and used. In this case,

when the prompt command was added, it caused the router to use that text and not the

hostname as the prompt.

2. No practical effect. Because no other Cisco CDP enabled devices are on that Ethernet,



CDP messages from Gorno are useless. So, the only effect is to lessen the overhead on that

Ethernet is a very small way.

3. No effect other than cleaning up the configuration file. The enable password is not used



if an enable secret is in use.



Scenario 2-2 Answers

The answers to the questions in Scenario 2-2 are as follows:

1. The first boot system statement would be used: boot system tftp 134.141.88.3 c2500-js-



113.bin.

2. The boot system flash command would be used. The TFTP boot would presumably fail



because there is not currently a route to the subnet the TFTP server is part of. It is

reasonable to assume that a route would not be learned two minutes later when the router

had reloaded. So, the next boot system command (flash) would be used.

3. The boot system ROM command would be used. Because there is no file in Flash called



c2500-j-l.111-9.bin, the boot from Flash would fail as well, leaving only one boot

command.

4. The IOS from ROM would be loaded due to the configuration register. If the configuration



register boot field is set to 0x1, boot system commands are ignored. So, having a route to

the 134.141.88.0/24 subnet, and having c2500-j-l.111-9.bin in Flash, does not help.



04.35700737 CH03 Page 70 Wednesday, February 17, 1999 2:45 PM



The following table outlines the CCNA exam objectives that are reviewed in this chapter.

The numbers shown correspond to the master list of objectives found in Chapter 1, “What

Is CCNA?”



Objective



Description



1



Identify and describe the functions of each of the seven layers of the OSI

reference model.



2



Describe connection-oriented network service and connectionless network

service, and identify the key differences between them.



3



Describe data link addresses and network addresses, and identify the key

differences between them.



4



Identify at least 3 reasons why the industry uses a layered model.



5



Define and explain the 5 conversion steps of data encapsulation.



6



Define flow control and describe the three basic models used in networking.



7



List the key internetworking functions of the OSI Network layer and how

they are performed in a router.



29



Describe the two parts of network addressing, then identify the parts in

specific protocol address examples.



60



Define and describe the function of a MAC address.



04.35700737 CH03 Page 71 Wednesday, February 17, 1999 2:45 PM



CHAPTER



3



Understanding the OSI

Reference Model

In years past, the need to understand the Open Systems Interconnection (OSI) reference

model for networking grew rapidly. The U.S. government passed laws requiring vendors to

support OSI software on their systems or they would no longer buy the systems. Several

vendors even predicted that the global Internet would evolve towards using OSI as the

protocol instead of TCP/IP. As we near the turn of the century, however, OSI has been

implemented on a much smaller scale than predicted. Few vendors push their OSI software

solutions, if they have them. Several components of the OSI model are popularly

implemented today. For example, OSI NSAP network layer addresses are often used for

signaling in Asynchronous Transfer Mode (ATM) networks. However, full seven-layer OSI

implementations are relatively rare today.

So why have a whole chapter on OSI? The biggest reason is that the OSI seven-layer

reference model is an excellent point of reference for describing the concepts and functions

behind other network protocol implementations. References to Layer 2 switching and

Layer 3 switching, which are popular topics today, refer to the comparison to Layers 2 and

3 of the OSI model. Cisco courses make generous use of the OSI model as reference for

comparison of other network protocol implementations. So, this chapter will not actually

help you understand OSI fully, but rather it will discuss OSI functions in comparison with

popularly implemented protocols.



How to Best Use This Chapter

By taking the following steps, you can make better use of your study time:







Keep your notes and answers for all your work with this book in one place for easy

reference.







Take the quiz and write down your answers. Studies show retention is significantly

increased through writing facts and concepts down, even if you never look at the

information again!







Use the diagram in Figure 3-1 to guide you to the next step in preparation for this topic

area on the CCNA exam.



04.35700737 CH03 Page 72 Wednesday, February 17, 1999 2:45 PM



72



Chapter 3: Understanding the OSI Reference Model



Figure 3-1 How To Best Use This Chapter

Low score



High score

Do I know this already? Quiz



Medium score



Read Chapter



Review Chapter

using charts and

tables



High

score

want

more

review

Skip Chapter



Next Chapter



NA260801



End-of-chapter

exercises



“Do I Know This Already?” Quiz

1. Name the seven layers of the OSI model.



______________________________________________________________________

______________________________________________________________________

______________________________________________________________________

2. What is the main purpose of Layer 3?



______________________________________________________________________

______________________________________________________________________

______________________________________________________________________



04.35700737 CH03 Page 73 Wednesday, February 17, 1999 2:45 PM



“Do I Know This Already?” Quiz



73



3. What is the main purpose of Layer 2?



_______________________________________________________________________

_______________________________________________________________________

_______________________________________________________________________

4. Describe the process of data encapsulation as data is processed from creation until it exits



a physical interface to a network. Use the OSI model as an example.

_______________________________________________________________________

_______________________________________________________________________

_______________________________________________________________________

5. Describe the services provided in most connection-oriented protocol services.



_______________________________________________________________________

_______________________________________________________________________

_______________________________________________________________________

6. Name three terms popularly used as a synonym for MAC addresses.



_______________________________________________________________________

_______________________________________________________________________

_______________________________________________________________________

7. What portion of a MAC address encodes an identifier representing the manufacturer of the



card?

_______________________________________________________________________

_______________________________________________________________________

_______________________________________________________________________

8. Name two differences between Layer 3 addresses and Layer 2 addresses.



_______________________________________________________________________

_______________________________________________________________________

_______________________________________________________________________



04.35700737 CH03 Page 74 Wednesday, February 17, 1999 2:45 PM



74



Chapter 3: Understanding the OSI Reference Model



9. How many bits in an IP address?



______________________________________________________________________

______________________________________________________________________

______________________________________________________________________

10. Name the two main parts of an IP address. Which part identifies which “group” this



address is a member of?

______________________________________________________________________

______________________________________________________________________

______________________________________________________________________

11. Name at least three benefits to layering networking protocol specifications.



______________________________________________________________________

______________________________________________________________________

______________________________________________________________________

12. Describe the differences between a routed protocol and a routing protocol.



______________________________________________________________________

______________________________________________________________________

______________________________________________________________________

The answers to the quiz are found in Appendix B, on page 549. Review the answers, grade your

quiz, and choose an appropriate next step in this chapter based on the suggestions diagrammed

in Figure 3-1. Your choices for the next step are as follows:









5 or fewer correct—Read this chapter.







9 or more correct—If you want more review on these topics, skip to the exercises at the

end of this chapter. If you do not want more review on these topics, skip this chapter.



6, 7, or 8 correct—Review this chapter, looking at the charts and diagrams that

summarize most of the concepts and facts in this chapter.



04.35700737 CH03 Page 75 Wednesday, February 17, 1999 2:45 PM



The OSI, TCP/IP, and Novell NetWare Network Protocol Architectures



75



Foundation Topics

The OSI, TCP/IP, and Novell NetWare Network Protocol

Architectures

CCNA Objectives Covered in This Section

1



Identify and describe the functions of each of the seven layers of the OSI reference model.



2



Describe connection-oriented network service and connectionless network service, and

identify the key differences between them.



4



Indentify at least 3 reasons why the industry uses a layered model.



5



Define and explain the 5 conversion steps of data encapsulation.



7



List the key internetworking functions of the OSI Network layer and how they are performed

in a router.



This chapter deals with many of the theoretical concepts and procedures defined as portions of

networking protocols. Four topics of particular importance for the CCNA exam are covered in

this chapter. The OSI model is described. (Expect questions on the functions of each layer.)

Data-link protocols and network layer protocols, the protocols most important to switching and

routing, are reviewed. Plus, an anecdote from the classroom that helps you remember what

routing and routing protocols are!

Three topics of particular importance for the CCNA exam are covered in this chapter:







The OSI model—Expect questions on the functions of each layer and examples at each

layer in the CCNA exam.









Data-link protocols—This section is important to properly understand LAN switching.

Network layer protocols—This section is important to properly understand routing.



If you come from the OJT or college training track (see Chapter 1), a full reading of this chapter

is probably in your best interest. If you have taken the ICRC training track, the data-link (Layer

2) details might be of the most interest to you. Finally, as usual, if you took the CRLS training

track, these concepts should have been fully covered in class, and you are more likely to be able

to pick and choose topics from this chapter.



OSI: Origin and Evolution

The difficulty in these last years of the century, when using the OSI protocol specifications as

a point of reference, is that almost no one uses them. You cannot typically walk down the hall

and see a computer whose main, or even optional, networking protocols are defined by OSI.



04.35700737 CH03 Page 76 Wednesday, February 17, 1999 2:45 PM



76



Chapter 3: Understanding the OSI Reference Model



So what is OSI? It is the Open Systems Interconnection model for communications. It is a rather

well-defined set of protocol specifications with many options for accomplishing similar tasks.

Some participants in OSI’s creation and development wanted it to become the networking

protocol and have all applications use OSI. The United States government went so far as to

require OSI support on every computer it would buy as of a certain date in the early ’90s via an

edict called the Government OSI Profile (GOSIP), which certainly gave vendors some incentive

to write OSI code. In fact, in my old IBM days, we even had charts showing how the TCP/IP

installed base would start declining by 1994, OSI installations would take off, and OSI would

be the protocol that the twenty-first century Internet was built from. (In IBM’s defense, moving

the world to OSI may have been yet another case of “You just can’t get there from here.”)

What is OSI today? Well, the protocols are still in existence and are used around the world to

some degree. The United States government reversed its GOSIP directive officially in May

1994, which was probably the final blow to the possibility of pervasive OSI implementations.

Cisco routers will route OSI. OSI Network Service Access Point (NSAP) addresses are used in

Cisco ATM devices for signaling. Digital Equipment’s DECnet Phase V uses several portions

of OSI, including the networking layer (Layer 3) addressing and routing concepts. But more

often than not, in 1998 (at the writing of this book), the OSI model is mainly used as a point of

reference for discussing other protocol specifications.



OSI Layers

The OSI model consists of seven layers each of which can, and typically does, have several

sublayers. The CCNA exam should not cover any sublayers with the exception of the sublayers

for Local Area Network (LAN) Data Links; the names of the OSI model layers and their main

functions are simply good things to memorize. And frankly, if you want to pursue your Cisco

certifications beyond CCNA, these names and functional areas will come up continually. Table

3-1 diagrams the seven OSI layers.

Table 3-1



OSI Reference Model

Layer Name



Functional Description



Examples



Application

(Layer 7)



An application that communicates with other computers

is implementing OSI application layer concepts. The

application layer refers to communications services to

applications. For example, a word processor that lacks

communications capabilities would not implement code

for communications, and word processor programmers

would not be concerned about OSI Layer 7. However, if

an option for transferring a file were added, then the

word processor would need to implement OSI Layer 7

(or the equivalent layer in another protocol

specification).



FTP, WWW browsers,

Telnet, NFS, SMTP

gateways (Eudora,

CC:mail), SNMP, X.400

mail, FTAM



04.35700737 CH03 Page 77 Wednesday, February 17, 1999 2:45 PM



The OSI, TCP/IP, and Novell NetWare Network Protocol Architectures



Table 3-1



77



OSI Reference Model (Continued)

Layer Name



Functional Description



Examples



Presentation

(Layer 6)



This layer’s main purpose is defining data formats, such

as ASCII text, EBCDIC text, binary, BCD, and JPEG.

Encryption is also defined by OSI as a presentation

layer service. For example, FTP allows you to choose

binary or ASCII transfer. If binary, the sender and

receiver do not modify the contents of the file. If ASCII

is chosen, the sender translates the text from the

sender’s character set to a standard ASCII and sends the

data. The receiver translates back from the standard

ASCII to the character set used on the receiving

computer.



TIFF, GIF, JPEG, PICT,

ASCII, EBCDIC,

encryption, MPEG,

MIDI, HTML



Session

(Layer 5)



The session layer defines how to start, control, and end

conversations (called sessions). This includes the

control and management of multiple bidirectional

messages so that the application can be notified if only

some of a series of messages are completed. For

example, an Automated Teller Machine transaction in

which you get cash out of your checking account should

not debit your account and fail before handing you the

cash, and then record the transaction even though you

did not receive money. The session layer creates ways to

imply which flows are part of the same session and

which flows must complete before any is considered

complete.



RPC, SQL, NFS, NetBios

names, AppleTalk ASP,

DECnet SCP



Transport

(Layer 4)



Layer 4 includes the choice of protocols that either do

or do not provide error recovery. Reordering of the

incoming data stream, when packets arrive out of order

is included, as well as reassembly of the data if the

packets fragmented during transmission. For example,

TCP may give a 4200 byte segment of data to IP for

delivery. IP will fragment the data into smaller sizes if a

4000 byte packet could not be delivered across some

media. So, the receiving TCP might get three different

segments or 1400 bytes apiece. The receiving TCP

might receive these in a different order as well, so it

reorders the received segments, compiles them into the

original 4200 byte segment, and then is able to move on

to acknowledging the data.



TCP, UDP, SPX



continues



04.35700737 CH03 Page 78 Wednesday, February 17, 1999 2:45 PM



78



Chapter 3: Understanding the OSI Reference Model



Table 3-1



OSI Reference Model (Continued)

Layer Name



Functional Description



Examples



Network

(Layer 3)



This layer defines end-to-end delivery of packets. To

accomplish this, the network layer defines logical

addressing so that any endpoint can be identified. It also

defines how routing works and how routes are learned

so the packets can be delivered. The network layer also

defines how to fragment a packet into smaller packets to

accommodate media with smaller maximum

transmission unit sizes. The network layer of OSI

defines most of the details that a Cisco router considers

when routing OSI. For example, IP running in a Cisco

router is responsible for examining the destination IP

address of a packet, comparing that address to the IP

routing table, fragmenting the packet if the outgoing

interface requires smaller packets, and queuing the

packet to be sent out to the interface.



IP, IPX, AppleTalk DDP



Data link

(Layer 2)



The data link (Layer 2) specifications are concerned

with getting data across one particular link or medium.

The data-link protocols define delivery across an

individual link. These protocols are necessarily

concerned with the type of media in question; for

example, 802.3 and 802.2 are specifications from the

IEEE, which are referenced by OSI as valid data-link

(Layer 2) protocols. These specifications define how

Ethernet works. Other protocols, like High-Level Data

Link Control (HDLC) for a point-to-point WAN link,

deal with the different physical details of a WAN link.

OSI, like other protocol specifications, often does not

create any original specification for the data link layer

but instead relies on other standards bodies such as

IEEE to create new data link and physical layer

standards.



Frame Relay, HDLC,

PPP, IEEE 802.3/802.2,

FDDI, ATM, IEE 802.5/

802.2



Xem Thêm
Tải bản đầy đủ (.pdf) (638 trang)

×